arch-pkgs/python-smbmc/PKGBUILD

35 lines
855 B
Bash

# Maintainer: George Rawlinson <george@rawlinson.net.nz>
pkgname=python-smbmc
_pkgname=smbmc
pkgver=0.2.0
pkgrel=4
pkgdesc="Supermicro BMC interface"
arch=('any')
url="https://github.com/grawlinson/smbmc"
license=('GPL')
depends=('python-requests' 'python-defusedxml')
makedepends=('python-build' 'python-install' 'python-poetry-core')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
b2sums=('f73f077de5e2b7e6cb96a19a9eb952f8274e0cb1b5980437b365d6586ef557bbdd494362f301737776c924de2f580d91eec4e45ed18c32dd712b37565fb98784')
build() {
cd "$_pkgname-$pkgver"
python -m build \
--wheel \
--skip-dependency-check \
--no-isolation
}
package() {
cd "$_pkgname-$pkgver"
python -m install \
--optimize=1 \
--destdir="$pkgdir" \
dist/*.whl
install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}